Jump to content

Labview
 Share

Vi può interessare?  

32 members have voted

  1. 1. Vi può interessare?

    • Si
    • No
      0
    • Non lo so
      0


Recommended Posts

ho un'altro asus da riparare: questa volta è un Asus X55c, cui se collegato alla corrente,

la batteria va in carica, ma se premo il tasto di accensione, si accende per 2-3 secondi, e si spegne.

dal bios chip ho fatto un backup, e ho già pronto anche un chip uguale per sostituzione.

chiedo aiuto, perché ho letto la pagina su informaticanapoli (speri sia concesso, altrimenti cancello riferimento), cito testualmente:

Con un editor esadecimale come Ultraedit, Notepad ++ o Cygnus Hex editor prendo il contenuto del Bios scaricato dal sito Asus a partire da 0x80000 e lo incollo nel file ‘base’ scaricato dal chip a partire dall’indirizzo 0x200000.

non capisco come si arriva a quegli indirizzi, considerando che tutti sw menzionati li ho.

allego bios parziale recuperato.

x55c backup.bin

@Labview

Edited by Albo89
Link to comment
Share on other sites



Buongiorno a tutti

Qualcuno ha mai aggiornato i vari moduli agesa/ncpucode su motherboard Gigabyte con bios award?

Sto notando che è abbastanza complicato per via dei moduli MEMINT; HT; HT32GATE posti alla fine della struttura e che non possono essere spostati.

Ho provato ad usare un "dummy module" prima dei moduli sensibili ma purtroppo non riesco a dimensionarlo correttamente anche dopo aver riscritto manualmente tutta la struttura del bios con cbrom 1.55.

Qualcuno saprebbe indirizzarmi su come fare?

 

Grazie

Link to comment
Share on other sites

In attesa che @Labview ci possa dare una mano voglio condividere i miei progressi sulle ricerche che sto facendo per modificare il bios della mia scheda madre.

Il mio intento è quello di rendere compatibile una vecchia scheda madre AM2 gigabyte con la famiglia di cpu phenom x6, attualmente il supporto ufficiale si ferma ai phenom x4.

I moduli del bios da andare ad aggiornare sarebbero essenzialmente 3: AGESA; NCPUCODE;  MEMINIT

Il modulo AGESA contiene le librerie delle cpu che sarà utilizzata.

Il modulo NCPUCODE non fa altro che andare ad indirizzare il sistema verso la libreria AGESA una volta individuata la CPU.

Il modulo MEMINIT è legato alla memoria ram e andandolo ad analizzare con un editor HEX ho notato che ci sono dei riferimenti alle librerie AGESA presenti nel modulo AGESA.

Ho trovato in rete questa guida che spiega come andare a modificare i moduli all’interno della struttura del bios.

In pratica la dimensione della somma dei moduli che si trovano prima dei moduli sensibili non deve variare, ho visto che si usano escamotage come rimuovere o spostare moduli non necessari, ad esempio il modulo PXE della LAN, sostituire i moduli da aggiornare seguendo la precedente struttura ed infine inserire un modulo “dummy” di modo che ci sia sempre la stessa dimensione prima dei moduli sensibili.

Come andare a modificare i moduli AGESA e NCPUCODE mi è chiaro, l’unico dubbio che ho è come andare a modificare il modulo MEMINIT con uno aggiornato visto che si tratta di un modulo sensibile.

Arrivato a questo punto non mi resta altro andare a sperimentare un po' di combinazioni sperando di trovare quella giusta.

Prima di tutto però devo procurarmi un programmatore usb per andare a riflashare il bios visto che sicuramente andrò a briccare la mobo.

In allegato la foto del bios della mia scheda madre, avevo intenzione di prendere lo stracollaudato CH341A più la pinza SOIC8 visto che non ho ne intenzione ne le capacità di andare a dissaldare/saldare ogni volta il chip dalla mobo, dovrebbero essere entrambi compatibili con il chip bios della scheda madre, la mia unica perplessità è a proposito delle tensioni richieste dal bios, ho letto in rete che alcuni bios necessitano di 1.8v altri di 3.3v altri ancora 5.0v, dove trovo le info relative alla tensione richiesta da questo chip? In caso di necessità posso flashare direttamente l'immagine del bios che trovo sul sito del produttore o devo andare prima a modificarla in qualche modo?

Grazie a chi saprà rispondermi

Saluti

Bios chip ga ma 69vm s2.jpg

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...
Il 19/5/2019 at 10:27, darkmercury dice:

Ecco il file del bios. L'ho gia aperto mmtool e lo apre correttamente. Vediamo se riesco a farci girare questo : Piccolo mostriciattolo

BIOSOLD.ROM 512 kB · 7 downloads

Poco fa sono riuscito a rimettere a posto il PC:yeah:, stranamente ho dovuto farlo riprogrammare una seconda volta,  dopo finalmente è riuscito ad avviarsi.

Ovviamente devo dire ancora grazie a darkmercury, :ave::ave::ave::ave::ave::ave::ave::ave::ave::ave: il Bios che mi ha fornito è quello giusto.

Link to comment
Share on other sites

11 ore fa, [email protected] dice:

Poco fa sono riuscito a rimettere a posto il PC:yeah:, stranamente ho dovuto farlo riprogrammare una seconda volta,  dopo finalmente è riuscito ad avviarsi.

Ovviamente devo dire ancora grazie a darkmercury, :ave::ave::ave::ave::ave::ave::ave::ave::ave::ave: il Bios che mi ha fornito è quello giusto.

Prego. Devo metterlo da parte nel caso che altri, se qualcuno ha ancora queste mobo, dovesse trovare l' update sbagliato .

Link to comment
Share on other sites

Ho una MB ASUS P4S533-VM che vorrei far ripartire, è una SKT478 per CPU fino a FSB533, chipset SiS962, l'avevo messa via tempo fa, adesso provando il suo chip BIOS (SST 39SF020A da 2M-bit 256K X8) non viene rilevato.
Questo mi fa pensare che sia possibile che il chip sia guasto o abbia qualche problema, quindi pensavo di cambiarlo con un'altro recuperato da un'altra MB simile e riprogrammarlo con il BIOS della P4S533-VM.

Il chip che ho trovato è sempre un 2M-bit della stessa marca SST, però è un 49LF002A, mi chiedevo se secondo voi sia possibile usarlo per rimpiazzare il 39SF020A oppure no.

Grazie in anticipo

Link to comment
Share on other sites

  • 10 months later...

Ciao a tutti. 

Ho sempre aggiornato il bios da usb, questa volta ho provato il tool integrato nel Bios della scheda, al termine dell operazione una finestra conferma l'avvenuto aggiornamento e chiede di riavviare ma il PC non parte più. Ho provato a togliere batteria e riavviare ma niente. Credo si sia briccato il bios ma mi chiedo se possa essere altro.. 

 

Asrock 970 pro3 r2.0 

16gb ddr3

Fx 8320  

Ad ogni modo, ho estratto il chip dalla mobo, ed è un winbond 25q32fvaiq 

Se volessi sostituirlo con uno nuovo che chip dovrei comprare? I motori di ricerca non trovano risultati per questo specifico modello ma di simili e non so se possono essere compatibili, cosa mi consigliate? 

In oltre su alcuni siti ho visto che è possibile richiedere chip con l'ultimo Bios della scheda già caricato sopra sono affidabili? Prezzi da 10 a 15e

 

Ovviamente comprando un chip vuoto avrò bisogno di un programmatore, ho visto che ne esistono di economici a 4/5e che dite funzionano? 

Edit-

Dimenticavo penso sia brikkato il bios perché le periferiche mouse e tastiera non si accendono all accensione del pc ne dal pannello frontale del case ne dal pannello dietro della cheda madre 

Edited by ciberjack
Link to comment
Share on other sites

Vedi il datasheet
 

https://datasheetspdf.com/pdf/1461640/Winbond/25Q32FVAIQ/1

W25Q32FV  ...
 

Ma il tuo chip è nel formato DIP8 cioè con i piedini che vanno nello zoccolo (8 piedini) e non a saldare (SOIC8).

Qui lo vendo anche programmato BIOS CHIP - ASROCK 970 PRO3 / EXTREME3 / PRO3 R2.0 / EXTREME4 / A780GM-LE/128M

https://www.ebay.com/itm/BIOS-CHIP-ASROCK-970-PRO3-EXTREME3-PRO3-R2-0-EXTREME4-A780GM-LE-128M-/312639186141

https://www.ebay.it/itm/BIOS-Chip-ASROCK-970M-PRO3-980DE3-U3S3-R2-0-990FX-EXTREME6-B85M-HDS-R2-0/201410624871?hash=item2ee5023d67:g:D2YAAOSwpDdU4wqW

I Programmatori funzionano anche su Win10 , tuttavia installare i drivers è più difficile ..., comunque ti consiglio di prenderlo già programmato , lo infili nello zoccolo e vai ...

 

  • Thanks 1
Link to comment
Share on other sites

Grazie delle risposte ragazzi 

@BDMaster 

Una volta scaricato il datasheet quali valori dovrei confrontare con un chip da acquistare per verificare la compatibilità ?  Ultimamente sto smanettando spesso e chissà che non mi prendo uno di quei programmatori :asd:

 

Per i chip pronti avevo visto gli stessi ma non ricordavo se si potevano mandare i link è da parecchio che non scrivo. 

@principino1984

Sisi infatti è quello che farò adesso speriamo bene poi vi faccio sapere

Link to comment
Share on other sites

Devi controllare questi parametri :

SPI Flash 32 bit Dual/Quad SPI e 3volt di alimentazione e formato DIP8.

Trovi nelle pagine del datasheet ogni informazione, chiaramente dovrai verificare la piedinatura ed i segnali assegnati ai piedini,

il nuovo chip deve rispettare la piedinatura di quello esistente ed avere la tensione di lavoro intorno ai 3V, allego le foto da pdf ...

Eeprom.jpg

Eeprom1.jpg

 

Altrimenti potresti prendere la versione SOIC8 e saldarla su di uno zoccolo DIL8 oppure infilarlo in uno ZIF8 con piedini, insomma molte scelte per adattatori !

Zoccolo.jpg

Zoccolo1.jpg

Zoccolo2.jpg

Edited by BDMaster
  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 months later...
Il 25/4/2017 at 16:53, deltazor dice:

Ciao il problema sta nel chip fisico:AAAAH:, oggi ho programmato tutte e 2 i chip in mio possesso uno parte l'altro no, con il file bios 3401 che mi hai inviato, inoltre ti farà sicuramente piacere che la mb non presenta più il bug del boot che in tanti lamentano (tempi di avvio lunghi, prima dei tuoi bios se si aveva un bios a 3xxx il pc si bloccava in fase di boot x 10sec QCODE 00 poi partiva) cmq ti allego anche il file letto dal chip bios 3401 in prestito, da quello che vedo la diff sta nel LAN MAC come giusto che sia che nel UUID: e MBSN: nel file write usbflashback ho notato che

UUID: DDDDDDDDDDDDDDDDDDDD708BCD579998

MBSN: 111111111111111,

in quello letto dal chip in prestito invece sono

UUID: 40C4105EDAD7DD11AE6D2C56DC3E57E6

MBSN: 151260470101338

 

https://1drv.ms/f/s!ArBkX-7q0qvb2iGA--EFQQik-YEl

 

Ti ho allegato il link della cartella dove ci sono tutti i bios provati,in ognuno di essi c'è un file di testo con i risultati delle prove.

Adesso sto utilizzando il tuo file bios 3401 e gli ho clonato le info estratte tramite FD44Editor dal bios MAXIMUS-VIII-HERO-2001 write usbflashback,volevo recuperare il LAN MAc originale con esito positivo.

Cmq 1 cosa e certa sulle MAXIMUS-VIII-HERO usbflashback non funzione su un chip vuoto cosa ce invece avveniva sulla mia MAXIMUS-VII-HERO.

Girando in internet mi sono imbattuto in questo:

https://hardforum.com/threads/tools-to-flash-and-recover-bios-on-asus-p8xxx-boards-fd44editor-ftk.1726429/

https://forums.overclockers.ru/viewtopic.php?p=9776728#p9776728 forse può servire.

 

Spero di essere stato d'aiuto, fammi sapere e grazie x tutto quello che hai fatto

Ciao io sto impazzendo con la maximum vii hero sapresti aiutarmi a flesciare con flaschback il bios?

 

  • Like 1
Link to comment
Share on other sites

  • 1 year later...

Buon Giorno, vi spiego il mio problema se qualcuno di buon cuore riesci ad aiutarmi.

Premessa ho un portatile HP 250 G5, con all'interno una scheda madre la-d704p rev.3.0 (non funzionante per problemi di alimentazione) ho recuperato su internet 2 schede simili ma che dovrebbero essere compatibili, entrambe sono la-d703p rev.3.0, le cui due schede mi confermano i rivenditori sono funzionanti al 100%, però una volta montate con entrambe le schede lampeggia il caps lock per 3 volte, la ventola gira ma il pc non parte con display nero. Ho provato ad estrapolare con il programmatore CH341A con software CH341A Programmer v1.44 i bios originali e immettere anche alcuni trovati su internet ma con alcuni bios i lampeggi sono passati la 3 a 1 e la ventola si accendeva per pochissimo, con altri sempre lo stesso problema dei 3 lampeggi e la ventola si azionava in maniera credo regolare. Sono costretto ogni volta a dissaldare il cip altrimenti il programmatore non lo riconosce. 

Spero di essere riuscito in queste righe a spiegare i miei esperimenti, essendo alle prime armi, ma mi piace appunto sperimentare, chiedo gentilmente se riuscite ad aiutarmi a capire se sto sbagliando tutto e se i miei ragionamenti sono sbagliati.

Allego il bios originale estrapolato dal cip della scheda originale e il bios di una delle due schede acquistate da internet.

Bios Originale prima scheda la-d703p rev.3.bin Bios Originale Scheda la-d704p rev.3.bin

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...