Jump to content

Labview
 Share

Vi può interessare?  

32 members have voted

  1. 1. Vi può interessare?

    • Si
    • No
      0
    • Non lo so
      0


Recommended Posts

Ok ma dovresti provare ad aggiornare ora alla versione 2.20 da windows per vedere se blocca o meno tali funzionalità perchè non ho ben capito se questa prova è già stata eseguita.

Se tutto va a buon fine e mantiene tutte le funzionalità allora puoi estrarre il chip per l'ultima volta ed eseguire un backup personalizzato tramite programmatore.

In caso contrario puoi contattare ASRock e chiedere info a riguardo, ti rispondono di sicuro.

L'aggiornamento alla versione 2.20 oltre al supporto Ivy Bridge include anche tutte le funzionalità per windows 8.1/10 (fast boot ecc..)

 

Capisco che sia una grande rottura di scatole tutto questo ma sei un passo dalla fine... O0

 

P.S. che processore utilizzi?

Non avrei voluto farlo, ma alla fine mi son deciso, così da soddisfare il tuo dubbio. Ebbene, ho brickato il PC esattamente come la prima volta, il che per lo meno ha dimostrato che è tutta colpa di ASRock. Infatti, una volta avviato il programma di aggiornamento del BIOS, inizia a scrivere l'NVRAM, scrive il Boot Block, poi quando inizia con il Main BIOS, arriva a circa 7 blocchi e crasha Windows, lasciandoti senza alcuna speranza. Questa volta (ben la quarta) il pit stop smonta/rimonta è stato ancora più traumatico, in quanto ho quasi rischiato di rompere un pin del chip, e una volta rimontato tutto, clicco il bottone di accensione e non parte nulla, nemmeno un led. Inizio a sudare veramente freddo, ma con calma stacco il cavo di alimentazione, lascio passare 1 minuto e riattacco, e per fortuna il PC è ripartito. Inutile dire che non ci saranno altri tentativi da parte mia. Spero per lo meno che la mia esperienza possa essere utile ad evitare a qualche altro utente di passare attraverso lo stesso calvario. In ogni caso, l'aggiornamento del BIOS da Windows comporta la modifica solamente di 4MB/8MB di memoria del chip, ovvero i blocchi relativi a NVRAM, Boot Block e Main BIOS. Non ho dunque dubbi a riguardo del fatto che la logica contente il limite del moltiplicatore della CPU e della frequenza massima delle RAM risieda nei restanti 4MB non modificabili normalmente, nei quali sono contenuti l'Intel ME e il Flash Descriptor.

Link to comment
Share on other sites



@DarkStigma

 

Mi dispiace che l'aggiornamento manda tutto in blocco, ti consiglio di contattare ASRock ed esporre il tuo problema nei dettagli e del blocco che genera nell'aggiornamento.

Per esperienza ti consiglio di contattare il supporto olandese per il semplice fatto che molto probabilmente ti invieranno gratuitamente un nuovo chip o un nuovo bios.

Link to comment
Share on other sites

Salve ho letto la prima pagina di questo thread molto interessante. Vorrei comprendere come resettare le informazioni DMI del bios n modo che siano coerenti con l'attuale assetto. Ho tentato con diversi tool senza successo poichè i dati non si modificano oppure nel caso in cui l'editor esegue correttamente una delle modifiche accettate al riavvio tale rettifica è persa. Può dipendere dal chip winbond?

Link to comment
Share on other sites

Credo che puoi farlo solo con un programmatore

 

 

Grazie della replica. Il bios in questione è AWARD che tipo di programmatore potrei utilizzare!? Le cd utility DMIcfg.exe etc come anticipato sono risultate inutili. Non so se gli aspetti siano correlati ma in sostanza riscontro errori del MCH (PT880 PRO) nel gestire DUAL CHANNEL e Bank interleave. Sostanzialmente il dual channel opera anche con nr dispari moduli (1 o 3). Nel DMI il valore attribuito alle memoria è di fatto sbagliato adeguandosi ad un nr fisso e calcolando male le informazioni dei singoli moduli.

 

Che tool suggeriresti?

Link to comment
Share on other sites

i programmatori li trovi nei primi post con relativi link ai tool gentilmente ospitati da Labview sul suo minisito.

 

 

Grazie della replica. Disponendo del programmatore NANOBIOS PROGRAMMER ho la possibilità di flashare il bios nell'eeprom; esiste un software, o per caso altri tool sono adattabili per l'edit attraverso questo strumento?

Edited by Azrael5
Link to comment
Share on other sites

@Azrael5

Devi aggiornare il bios tramite awdflash utilizzando il comando /CD = clear dmi data after programming

Es: AWDFLASH xxxx.BIN /cd

 

Marca e modello della scheda madre?

 

 

salve, nella totalità dei casi ho eseguito l'aggiornamento bios tramite l'opzione CD ed altre opzioni, senza esito. Non so come questi dati siano sviluppati, calcolati o impressi nel bios stesso ma non mutano: i dati DMI sono completamente sbagliati.

 

Modello scheda madre Jetway pt88bspro-ec .

Link to comment
Share on other sites

salve, nella totalità dei casi ho eseguito l'aggiornamento bios tramite l'opzione CD ed altre opzioni, senza esito. Non so come questi dati siano sviluppati, calcolati o impressi nel bios stesso ma non mutano: i dati DMI sono completamente sbagliati.

 

Modello scheda madre Jetway pt88bspro-ec .

 

Anche nella pagina del download sono esposte le istruzioni di aggiornamento riportanti i comandi

"when using AWDFLASH(we recommend version newer than V8.83)to renew the BIOS of this version"/cd/cp/ch/wb/qi"parameters are required".

Se dopo queste istruzioni da applicare contemporaneamente non si ottine un riscontro positivo la causa potrebbe derivare dal chip difettoso o bloccato, l'unica alternativa è provare una cancellazione completa tramite programmatore.

Non escludo che potrebbe essere la scheda madre stessa ad avere problemi nel chipset.

Link to comment
Share on other sites

Esattamente, come premesso, aggiorno utilizzando oltre al parametro CD gli altri in elenco e ne ho aggiunti anche altri tipo QI ed R. originariamente avevo altra scheda madre analoga, ma causa test con cui avevo tentato di aggiornare le codifiche delle cpu era divenuta inutilizzabile.... dopo alcuni anni ho acquistato il nano bios programmer e l'ho recuperata... disponendo quindi di 2 schede madri analoghe ho installato entro la scheda madrea ddizionale, una eeprom con bios moddato, installati altro processore pentium 4 530J e 2 moduli ram OCZ platinum, una scheda video di riserva, avviato un sistema operativo linux, proceduto con il comando DMI DECODE da terminale per verificare che i dati DMI potessero essere differenti, ma invece sono i medesimi: gli slot ram sono intesi come tutti occupati con 512 single channel eccetto il 4° slot indicante un quantitativo di ram esorbitante in MB mi pare 32 mila MB di ram.

 

ps: non pensavo nemmeno il parametro "bank interleave" fosse appannaggio solo di taluni chipset legacy: VIA AMD e ULI/NFORCE.... intel pare abbia ignorato questo parametro per anni. In sostanza avrei voluto disporre del bank interleave anche quando 4 moduli di ram sono impiegati in Dual Channel, tuttavia penso che senza adeguata modifica bios sia impossibile. Mi spiace perchè in tal senso pur essendo datata è una scheda madre che offre singolarità soddisfacenti.

Edited by Azrael5
Link to comment
Share on other sites

Ma tu non hai problemi con il bios originale, vuoi tentare di forzare dei parametri con una MOD, giusto?

 

sostanzialmente l'idea era di impostare correttamente il DMI e come obbiettivo anche quello di rendere operativo il bank interleave anche in pres4enza di 4 moduli di memoria nel qual caso tale parametro è disattivato dal sistema. Suppongo che tale situazione è generata dal fatto che i sistema non riesca a gestire le informazini correttamente... pertanto potrebbe sussistere una correlazione tra DMI e disfunzione bank interleave.... in qualsiasi caso l'intento è sia quello di configurare correttamente le informazioni DMI o cmq di resettarle che di rendere operativo i bank interleave a 4-way. Il bank interleave 4-wau funziona correttamente quando son presenti solo 2 moduli.

 

Ora caso strano 2 moduli sarebbero necessari per il dual channel, ma come premesso in precedente post, il sistema erroneamente applica i dual channel in qualsiasi configurazione di ram, sia che sia presente un modulo, che siano presenti 3 moduli. In sostanza con 3 moduli avrei il bank interleave applicato e il dual channel attivo... sostanzialmente pare che il bios non mappi correttamente le memorie. Non che utilizzando 2 moduli da 256mb ciascuno le cose cambino. Feci delle prove in proposito. Probabilmente i giorni prossimi farò altri test con la scheda madre supplementare modificando le configurazioni hardware (per avere anche certezza di quanto affermato, poichè i test li ho eseguiti tempo addietro e a volte la memoria personale tradisce).

 

Per mod intendo il fatto che il bios è stato modificato con modbin6... aggiungendo funzioni accantonate. Tipo C1E e Performance Mode. Nell'ultima modifica ho cercato di inserire tutte le opzioni moddate proprio per verificare se cambia qualcosa.

Link to comment
Share on other sites

Il dual channel non è normale che si attivi con un solo modulo ma è corretto che sia attivo con 3 moduli.

Il problema del bank interleave probabilmente è causato dal tipo di memoria ram utilizzata, bisognerebbe provare con 4 moduli "single side" per capire se è un problema di mappatura.

Non ti posso aiutare per le MOD anche perchè questo non è il forum adatto ma se ti può servire ti consiglio una semplice utility "libera" per dare un occhio dentro il bios "http://rweverything.com/".

Attenzione a non fare danni permanenti!

Link to comment
Share on other sites

Il dual channel non è normale che si attivi con un solo modulo ma è corretto che sia attivo con 3 moduli.

Il problema del bank interleave probabilmente è causato dal tipo di memoria ram utilizzata, bisognerebbe provare con 4 moduli "single side" per capire se è un problema di mappatura.

Non ti posso aiutare per le MOD anche perchè questo non è il forum adatto ma se ti può servire ti consiglio una semplice utility "libera" per dare un occhio dentro il bios "http://rweverything.com/".

Attenzione a non fare danni permanenti!

 

Sì grazie della replica, nel caso di danni uso il nano programmer, cmq utilizzo quel tool esclusivamente per analizzare i bios e nel caso rielaborare la struttura. Quindi il nano programmer risulta nei casi di test uno strumento abbastanza utile.... ora lo sto usando proprio per diversificare le eeprom sostituendole alla scheda madre nel caso di test errati, com'è accaduto oggi in cui ho testato sulla scheda supplementare bios di scheda madre affine (Stesso chipset processore ram, ma lievi differenze del layout elettronico) ho sostituito la eeprom con il bios ufficiale ed ho risolto i problemi din instabilità sistemica.

 

 

Non sapevo che il dual channel fosse normale in 3 moduli di ram installati.

Edited by Azrael5
Link to comment
Share on other sites

ragazzi scusate (è da tanto che non flasho bios)

 

ma su bios che hanno estensione ".214" o comunque estensione numerica, come il bios di questo notebook x553ma della asus e di cui potete vedere il bios in funzione qui

 

 

come faccio a dare in pasto il file al programma del mio programmatore willem? lo rinomino semplicemente in bin o cosa?

Link to comment
Share on other sites

ragazzi scusate (è da tanto che non flasho bios)

 

ma su bios che hanno estensione ".214" o comunque estensione numerica, come il bios di questo notebook x553ma della asus e di cui potete vedere il bios in funzione qui

 

 

come faccio a dare in pasto il file al programma del mio programmatore willem? lo rinomino semplicemente in bin o cosa?

 

Come ha detto Tom basta rinominarlo, meglio ROM visto che è un AMI bios.

Da Willem Eprom puoi selezionare vari tipi di file tra cui l'estensione ROM. :)

Link to comment
Share on other sites

Solo per curiosità, in fase di decompressione cartella file relativa al PROGRAMMER NANO BIOS USB l'antivirus ha rilevato threat abbastanza pericolosi ha eseguito pulizia dei file riavviato ed ha corretto alcune modifiche che il malware avrebbe apportato. Occorre preoccuparsi?

Link to comment
Share on other sites

è anche specificato in prima pagina... :leggi:

 

* Caution

Some S/W is able to misdiagnose a Virus because of license protect code.

(like McAfee VirusScan, Kaspersky, Avast, Avira, etc...)

Please pause Antivirus[/url] S/W before run .

(or move S/W to safe-zone)

 

Falso positivo, disattivare l'antivirus. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...