Jump to content
everyname

TP-Link TL-WN322G Wireless USB Adapter - Problema installazione software InsDrvZD.DLL

Recommended Posts

Buongirno a tutti.

Ho acquistato il TP-Link TL-WN322G Wireless USB Adapter, ma alla fine della installazione del software di gestione (quindi prima di collegare il dispositivo al notebook) ricevo questo segnale di errore:

"Errore durante il caricamento di InsDrvZD.DLL. Impossibile caricare il modulo specificato."

 

Ecco i dettagli:

Il file InsDrvZD.DLL esiste e viene copiato nella cartella c:windowssystem32 durante l'installazione del software.

Il software è quello scaricato dal sito del produttore Welcome to TP-LINK.

Se cancello il file InsDrvZD.DLL il software ce lo rimette e ho ancora l'errore.

Firewall e antivirus disattivati.

Altri software di gestione schede WiFi disinstallati.

Il SO è Windows XP Professional SP1, e ho provato anche dopo l'aggiornamento a SP2.

L'errore compare appena termina l'installazione (infatti si apre la finestra con scritto "installazione terminata..." e ho la possibilità di cliccare su "Fine") e appena viene auto-avviata l'applicazione ZDWlan.exe (quella che gestisce il dispositivo TL-WN322G).

Se collego il dispositivo alla fine dell'installazione windows lo rileva ma non mi chiede di installare il nuovo hardware, e in gestione periferiche mi segnala un dispositivo wireless USB sconosciuto (con il punto esclamativo giallo) e non mi da la possibilità di installare o aggiornare i drivers.

Anche senza installare il software è impossibile installare manualmente i drivers.

Anche quando disinstallo il software mi da lo stesso errore per ben 3 volte di seguito.

 

Ho provato ad installare lo stesso software su un altro notebook (su cui c'è lo stesso Windows XP SP1 che ho sul mio) e funziona correttamente.

Ho provato ad attivare sul mio notebook gli stessi servizi windows attivi sul notebook su cui il dispositivo funziona. Ho provato anche attivandoli tutti ma ho sempre lo stesso messaggio d'errore.

 

Ho bisogno di utilizzare proprio questo dispositivo quindi devo farlo funzionare.

 

Potete aiutarmi?

Grazie.

Share this post


Link to post
Share on other sites


Benvenuto..

situazione assai strana...

hai provato per caso ad installare il software in modalità provvisoria di windows, poi riavviare il pc e quindi collegare il dispositivo??

 

il wi-fi l'hai preso nuovo?

hai la possibilità di cambiarlo con una marca diversa?

 

ciao

Share this post


Link to post
Share on other sites

Mi restano da fare queste prove:

- Installare il software in modalità provvisoria.

- Eseguire il file di installazione in modalità compatibile con Windows98.

- Provare a installare il software di un'altro modello (sempre TP-Link) per vedere cosa succede.

 

Il dispositivo funziona, l'ho provato su altri 2 pc (uno fisso e uno portatile) è nuovo e mi serve proprio questo modello perché ha la funzione Access Point.

Comunque sul mio notebook (quello che da problemi x intenderci) ne ho provati altri 2 di adattatori USB WiFi (uno Asus e uno D-Link) e funzionavano tutti e due (ma non avevano la funzione Access Point).

 

Stasera provo e posto i risultati. Nel frattempo ogni idea è ben accetta.

Share this post


Link to post
Share on other sites

Le prove non hanno dato buon esito, il problema è rimasto lo stesso.

Ho provato ad installare il software del modello TL-WN321G e questo non ha dato problemi (ma ovviamente il mio TL-WN322G non funziona con questo software).

 

Sembra come se ci fosse un conflitto software o qualcosa di simile...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×